点击登录
  • 静博客

用易语言写的腾讯云接口操作

源码分享 道木樱花 43次浏览 0个评论

接着来一个易语言版本腾讯云API操作

.版本 2
.支持库 spec

.程序集 窗口程序集_启动窗口

.子程序 _按钮1_被单击
.局部变量 SecretId, 文本型
.局部变量 SecretKey, 文本型

SecretId = “你的SecretId”
SecretKey = “你的SecretKey”
调试输出 (签名_URL (SecretId, SecretKey, “DescribeRegions”, “2017-03-12”, , ))

.子程序 签名_URL, 文本型
.参数 Secret_Id, 文本型, , SecretId
.参数 Secret_Key, 文本型, , SecretKey
.参数 执行方法, 文本型, , 请求方法
.参数 版本号, 文本型, , 格式:2017-03-12
.参数 地域参数, 文本型, 可空, 地域参数,有的方法中可为空
.参数 其他参数, 文本型, 可空, 请求方法中的其他参数
.局部变量 原成员组, 文本型, , "0"
.局部变量 N, 整数型
.局部变量 N1, 整数型
.局部变量 临时文本, 文本型
.局部变量 签名结果, 文本型
.局部变量 url, 文本型
.局部变量 data, 文本型

.如果真 (地域参数 ≠ “”)
    地域参数 = “&Region=” + 地域参数
.如果真结束
data = “Action=” + 执行方法 + “&Nonce=” + 时间_取现行时间戳 () + “&SecretId=” + Secret_Id + “&Timestamp=” + 时间_取现行时间戳 (真) + “&Version=” + 版本号 + 地域参数 + 其他参数
加入成员 (原成员组, 分割文本 (data, “&”, ))
.计次循环首 (取数组成员数 (原成员组), N)
    .变量循环首 (N + 1, 取数组成员数 (原成员组), 1, N1)
        .如果真 (原成员组 [N] > 原成员组 [N1])
            临时文本 = 原成员组 [N]
            原成员组 [N] = 原成员组 [N1]
            原成员组 [N1] = 临时文本
        .如果真结束

    .变量循环尾 ()
    签名结果 = 签名结果 + 原成员组 [N] + “&”
.计次循环尾 ()
url = “https://cvm.tencentcloudapi.com/?” + 签名结果
签名结果 = “GETcvm.tencentcloudapi.com/?” + 签名结果
签名结果 = b64_hmac_sha1 (Secret_Key, 文本_删右边 (签名结果, 1))
url = url + “Signature=” + 编码_URL编码 (签名结果, 真, 真)
返回 (url)

 


静博客 , 版权所有丨如未注明 , 均为原创丨本网站采用BY-NC-SA协议进行授权 , 转载请注明用易语言写的腾讯云接口操作
喜欢 (0)
[1158230257@qq.com]
分享 (0)
发表我的评论
取消评论
表情 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址